Here you can download the oryginal firmware for NiMH bikes 1017 - 3001.zip

This article was helpful for 10 people. Is this article helpful for you?

Where can I find the description of the firmware? What is does, what is different from the original? How to operate new features?

Jose

This is the oryginal Vectrix firmware for NiMH bikes - we don't develop any changes to NiMH only to the lithium. If you would like something newer for NiMH - check for Laird firmware on visvorvoltage

Hello, 


I uploaded nimh firmware on my runke charger to make a leaf conversion without bms


and now the red lights are flashing and the fan of the charger is on without pluging the charger in.


I tried to upload the lithium firmware back but it doesnt work.


Is there any reset possible or any trick to upload the lithium software back?


thanks for your answer


Jc Coen

please send a picture of charger hw revision, the serial number and revision are stamped on the charger  heatsink side

Is it this? 




Envoyé depuis un mobile Samsung


-------- Message d'origine --------
Attachments:
20170608_090040_resized.jpg
20170608_090029_resized.jpg
________________________________________
Attachments:
20170611_222920.jpg

this charger is ok for nimh or for lithium but need proper firmware, probably you put the esd charger firmware into the gold charger, try to upload the firmwere when the plug is in the AC

I plugged in the charger in the ac, with the battery plugged in, the fan goes on and off, every lights are on, the counter goes to the max then block to 40mph.

the same message appears when i try to program the battery charger:

"transfer failed to vxni vehicule charger"

Hello,

I changed today the charger for another gold charger witch comes from a vx1 Li+,


the fan and the lights stays off,


I tried to download a firmware but the can bus is off and red,


i checked the connection cable but it is allright.


The vectrix diagnostics GUI is still opening on "vectrix nimh" and not lithium.


Do yo have an idea?


Thank by advance


Jc Coen



I mounted the original charger back on vectrix and managed to download a lithium firmware on the charger, the red lights on the dashboard and the fan are off but now the mc and icm are red on the gui summary and it is not possible to download any firmware again.


Thanks by advance for jour answer


JC Coen